Monday, August 31, 2009

Don't panic! Adobe CS3 runs on Snow Leopard

InfoWorld has tested the Adobe CS3 apps in Snow Leopard and says they work fine, which I'm sure is a big relief to those of you running CS3 who want to upgrade to Snow Leopard but heard that Adobe will not support CS3 in Snow Leopard.

Which is what I think Adobe was really trying to say: The company notes it has not tested CS3 on Snow Leopard (and doesn't intend to), so it's not guaranteeing -- "supporting" -- CS3 on Snow Leopard. Adobe could have chosen better wording.

Read the full article here at InfoWorld.com.

If you want to upgrade to Adobe CS4, we have a bundle special that expires today! Adobe CS4 Bundle Upgrade Sale - Save $100 when you upgrade from an earlier version of Adobe Creative Suite, Production Studio, or Macromedia Studio to Creative Suite 4.

1 comment:

Todd Kopriva said...

If you're using After Effects CS4 with Snow Leopard, be sure to update to After Effects CS4 (9.0.2). A problem with Render Multiple Frames Simultaneously multiprocessing on Snow Leopard was fixed after the After Effects CS4 (9.0.0) release.